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CHAPTER

25

Every project requires communication and collaboration—and usually a lot of 
both. With small project teams, you and your team members may interact in 
a variety of ways: talk over cubicle walls, keep track of issues and statuses on 

your communal whiteboard, send emails or instant messages back and forth, and 
share files like Word documents and Excel spreadsheets via a network folder or in 
the cloud. With methods like these, however, the occasional detail might fall through 
the cracks or you may not hear about an issue until it’s out of hand.

If you’ve outgrown your small project ways (but haven’t graduated to needing 
enterprise-level project-management tools), you may be looking for more tightly-
knit team collaboration—a way to share project information with the entire team, to 
engage team members in solving problems, and to keep everyone in the loop about 
what’s going on with the project.

You might start out by setting up a SharePoint team site—a website you and your 
team members can use to share documents and other project information, track is-
sues, and post status reports. You can also share info about project work by creating 
SharePoint Tasks Lists. That way, team members can see what’s on their to-do lists, 
send progress updates as they complete work, and make changes to tasks. And you 
can easily check the status of tasks and, if necessary, modify them.

If you’re reading Microsoft Project 2013: The Missing Manual, chances are you use 
Project to plan and manage your project schedules. In that case, you may want an 
easy way to share task info with team members who don’t use Project. You can create 
tasks in either a Project file or a SharePoint Tasks List. Then, you can synchronize the 
tasks between the two programs. This synchronization gives you the best of both 
worlds: you can use Project’s scheduling features while still easily sharing tasks with 
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your team. The updates that team members submit through SharePoint synchronize 
with your Project file, as well.

 NOTE 	 If your organization requires enterprise-level project management (coordinating an entire portfolio 
of projects and sharing enterprise resources, for example), this simple synchronization feature won’t cut it. You 
need a solution that includes Project Server and SharePoint for those types of project-management activities. In 
fact, when Project Professional is connected to Project Server, the “Sync with SharePoint” option is disabled on 
Backstage view’s Save As and Share pages.

This chapter explains what you can do with SharePoint and Project, if you don’t use 
Project Server. You’ll learn how to share Project files to a SharePoint site. You’ll see 
how to create a Tasks List on a SharePoint site, publish tasks in Project to a SharePoint 
Tasks List, or convert a SharePoint Tasks List into a schedule in a Project file. This 
chapter then shows you how to synchronize tasks between Project and SharePoint. 
Finally, you’ll learn how to handle task updates that team members submit.

 NOTE 	 The steps in this chapter are based on a SharePoint site created with default settings. However, 
SharePoint offers numerous options for customizing SharePoint sites, so your site might differ significantly from 
what you see here. If you can’t find a command or element described in this chapter’s steps, ask your SharePoint 
administrator for help.

Sharing Project Info on a SharePoint Site
A SharePoint site is a great way to keep all your project information in one central-
ized location. This section describes methods for sharing files on a SharePoint site. 
The box on page 25-7 describes a few other nifty collaboration features you can 
set up on a SharePoint site.

Saving a Project File to SharePoint from within Project
Say you just added the finishing touches to a Project schedule and want to share 
the file with your team members via a SharePoint site. If you have the file open in 
Project, you can save it from there. But before you can do that, you need to add your 
SharePoint site as a Save As location in Project. Here are the steps:

1.	 Choose File→Save As.

Backstage view’s Save As page appears.

2.	 Click “Add a Place,” and then, on the right side of the page, click your 
SharePoint location.

The SharePoint location label varies depending on how you access SharePoint. 
For example, if you use SharePoint through an Office 365 account, you’ll see 
Office 365 SharePoint in the location list.
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3.	 In the “Add a service” dialog box, type the email address you use to log 

into SharePoint, and then click Next.

The Sign In dialog box appears, with the email address you typed in the User 
Id box.

4.	 Type your password in the Password box, and then click “Sign in.”

An Add Service message box tells you that the SharePoint location is being 
added to your Office account. After Office adds the location, the SharePoint 
site appears in your “Save and Sync” list, as shown in Figure 25-1.

FIGURE 25-1
After you click “Add a 
Place” and sign in to 
access your SharePoint 
site, it appears in the 
“Save and Sync” list. From 
then on, you can click the 
site’s name (here, that’s 
Project TMM) to navigate 
to folders on the site.

Once your SharePoint site is set up as a save location in Project, you can add a Project 
file to the site in a jiffy. Here’s what you do:

1.	 Make sure that the file you want to upload to SharePoint is the active file 
in Project.

A quick way to see which file is active is to look at the filename in the Project 
window’s title bar.

2.	 Choose File→Save As, and then click the SharePoint site’s name in the “Save 
and Sync” list.

The site’s folders that you’ve opened recently appear on the Backstage Save As 
page’s Recent Folders list, as shown in Figure 25-2 (background).

www.itbook.store/books/9781449357962

https://itbook.store/books/9781449357962


MICROSOFT PROJECT 2013: THE MISSING MANUAL25-4

SHARING 
PROJECT 

INFO ON A 
SHAREPOINT 

SITE

FIGURE 25-2
If the site folder you want 
appears in the Save As 
page’s Recent Folders 
list, click it to open the 
Save As dialog box to 
that folder. In the Save As 
dialog box (foreground), 
select the document 
library you want to save 
the file to. 

3.	 To open a recent folder, click its name. If the SharePoint site folder you want 
isn’t visible in the Recent Folders list, click Browse instead. 

Either way, the Save As dialog box opens to your SharePoint site (Figure 25-2, 
foreground).

 NOTE 	 Depending on the speed of your Internet connection, you might see a message box telling you that 
Project is contacting the server for information.
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4.	 In the Save As dialog box, select the document library in which you want to 

save the file, and then click Open. 

The Save As dialog box displays the contents of the document library, which is 
basically a collection of files in a digital repository.

5.	 In the Save As dialog box, click Save. (If you want to save the file with a dif-
ferent name, edit the name in the “File name” box first, and then click Save.)

Project saves the file to your SharePoint site.

Adding Files to a SharePoint Site within SharePoint
Storing files on a SharePoint site makes it easy to share your files with others. As 
long as they have access to the SharePoint site, they can download the files stored 
there. A SharePoint site comes in handy in other ways. Imagine you travel to an-
other office and your laptop dies en route. You can borrow a computer, go online, 
download the files you need from the SharePoint site, and continue working with a 
minimum of interruption.

You can upload any kind of file to a SharePoint site: Project files, Word documents, 
Excel spreadsheets, images, and so on. Here’s how:

•	 Upload a document. You can add a document to a SharePoint team site right 
on its Home page. (You can also work with documents on the site’s Documents 
page. To get there, on the Home page’s left, click Documents.) Click the “new 
document” link and then choose Upload Existing File from the pop-up menu 
shown in Figure 25-3. In the “Add a document” dialog box, click Browse, select 
the file you want to upload, and then click Open. (You can also drag and drop 
the file you want to upload onto the “new document” link to add it to the site.) 
Once the file is uploaded, it appears in the Documents list with the date and 
time it was last modified and who modified it.

•	 Download a document. To download a file to your computer, first click its 
filename in the Documents list to open it. Next, in the Web App’s menu bar, 
click File→Save As, and then click Download. In the File Download dialog box, 
click Save. Finally, in the Save As dialog box, navigate to the folder you want, 
and then click Save.
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FIGURE 25-3
You can upload or open 
documents from the 
SharePoint site’s Home 
page (shown here) or 
Documents page. Click the 
“new document” link to 
upload an existing file or 
create a new one. Once a 
file created with an Office 
application is uploaded, 
you can open it in the 
corresponding Web App 
by clicking its name in the 
Documents list.

 TIP 	 Opening a file created with an Office application (like Word and Excel) is as simple as clicking its filename 
in the Documents list, which opens the file in the corresponding Office Web App. For example, when you open a 
Word document, Microsoft Word Web App launches. On the Edit Document tab, choose “Edit in Word” if you want 
to take advantage of all the editing features Microsoft Word has to offer. For a few simple edits, choose “Edit in 
Word Web App” to edit the document in your browser instead.
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POWER USERS’ CLINIC

Revving Up Your SharePoint Site
Keeping project information organized and up to date is even 
easier when you use SharePoint in conjunction with other 
programs like Outlook, Exchange, or Lync. (Lync is a Microsoft 
product for communicating via instant message, video confer-
ence, online meeting, and other methods.) Here are a few of 
the integrated features you might want to explore:

•	 If you use Outlook and Exchange, you can set up a site 
mailbox to file all your project emails and documents. 
All the team members for the SharePoint site or project 
share the site mailbox’s email address. So if a team 
member files an email message or document using the 
site mailbox, that message or document is available to all 
team members. However, the messages and documents 
are still stored in their original locations. For more info on 
site mailboxes, head to http://tinyurl.com/stmbx.

•	 If you use Outlook and Exchange, you can sync tasks 
(Project tasks or personal tasks in Outlook) between 

Project, SharePoint, and Outlook. That means, you can 
mark tasks as complete in any of the three programs, 
and the tasks’ statuses propagate to the other programs. 
Learn more about this task integration at http://tinyurl.
com/tskint.

•	 If you use Lync to communicate with team members, you 
can message or call them from within Project to follow up 
on status. To do that, put your pointer over the person’s 
name in the Resource Name field and a Lync pop-up 
box appears, showing the person’s status in Lync, such 
as Away. Click the appropriate icon to send an instant 
message, call, initiate a video chat, or send an email. 
Head to http://tinyurl.com/lyncint to see how this Lync 
integration works.

 NOTE 	 To learn how to put SharePoint through all its paces, check out Microsoft SharePoint 2013 Plain & 
Simple by Johnathon Lightfoot, Michelle Lopez, and Scott Metker (O’Reilly).

Setting Up Tasks on a SharePoint Site
In SharePoint, a Tasks List is like a simple project plan with task names, start and 
finish dates, and so on. If you’re putting together a to-do list and don’t need all of 
Project’s bells and whistles, a SharePoint Tasks List might be just the ticket. You can 
assign team members who are part of the SharePoint site to tasks. You can organize 
tasks into an outline with summary tasks and subtasks; view start and finish dates; 
and show progress. You can also use a SharePoint Tasks List to brainstorm with your 
team. This section shows you how to create a SharePoint Tasks List within SharePoint.
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 NOTE 	 Once you add tasks to a Tasks List in SharePoint, you can also pull them into Project to build a schedule 
(page 25-18). In addition, you can publish a list of tasks that you built in Project to a SharePoint Tasks List for all 
to see (page 25-17).

Creating a Tasks List
To work with tasks on a SharePoint site, you need a Tasks List to hold them. In 
SharePoint 2013, you add the Tasks app to create a new Tasks List. (Similar to apps 
on mobile phones, SharePoint apps are mini-applications that expand what you can 
do with SharePoint.) Here’s how:

1.	 On the left side of the SharePoint site’s Home page, click Site Contents, and 
then, on the Site Contents page, click “add an app.”

The Site Contents page displays several popular apps.

2.	 Click the Tasks button.

The Adding Tasks dialog box appears.

3.	 In the Name box, type a name for the Tasks List, such as Catering Vendor 
Tasks, and then click Create.

The Site Contents page now includes a button for the Tasks List. The button’s 
label displays the name you entered for the list, as shown in Figure 25-4.

That’s it! If you want to create another Tasks List on the site, simply start anew at 
step 1.

FIGURE 25-4
You add another Tasks 
app to the site for each 
Tasks List you create. The 
name you enter when you 
create a Tasks List appears 
to the right of the Tasks 
List’s icon (which looks 
like a checkmark on a 
clipboard—reminiscent 
of a to-do list that you 
check off). You can make 
your Tasks Lists easier 
to identify by including 
the word “tasks” in their 
names. 
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 NOTE 	 There’s a shortcut for adding both a Tasks app and a Calendar app to your site (which you might want 
to do if you and your teammates prefer to look at your project work in a calendar view). On your SharePoint team 
site, click the “Working on a deadline?” icon. (If you don’t see this icon, click the gear-like Settings icon at the 
top right of the page, and then click Getting Started.) A dialog box containing a “Tasks (with a timeline)” and a 
Calendar icon appears; click Add Them.

Adding Tasks to a Tasks List
Once you’ve created a Tasks List, it’s time to add tasks to it. SharePoint 2013 Tasks 
Lists can be simple to-do lists or more sophisticated lists that include summary 
tasks and subtasks (page 25-14). In addition, you can link tasks (page 25-10) to one 
another to define predecessors and successors for a schedule. 

Here are the steps for adding tasks to a Tasks List:

1.	 On the left side of the site, click Site Contents, and then click the Tasks List 
you want to work on.

The Tasks List’s page opens with the Tasks List’s name at the top and a timeline 
below it.

2.	 On the Tasks List page, click “new task”

A task form appears with several commonly-used fields, such as Task Name, 
Start Date, Due Date, and Assigned To.

3.	 In the Task Name cell, type the task’s name, and then press Tab.

The Start Date box’s border is highlighted to indicate that it’s active.

4.	 Click the Calendar icon to the right of the Start Date box, and then choose 
the start date for the task. Alternatively, type the date in the box. Then, 
press Tab.

The Due Date box becomes active.

5.	 Enter the date that the task is due in the Due Date box, and then press Tab.

The Assigned To box becomes active.

6.	 To assign someone to the task, start typing the person’s name or email 
address in the Assigned To box, and then click the name you want in the 
drop-down list.

As you type, the Assigned To drop-down list shows matching names from the 
people who belong to the site, as shown in Figure 25-5.
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FIGURE 25-5
The Task Name field is the 
only field you have to fill 
in. To display additional 
fields, click Show More 
below the Assigned To 
label.

7.	 If you want to link the task to other tasks in the list, click Show More at the 
bottom of the page. In the Predecessors list box that appears, choose the 
predecessors to the task, and then click Add.

The predecessor task appears in the list box on the right. To remove a predeces-
sor, click the task in that list box, and then click Remove.

8.	 Click Save.

The task appears in the Tasks List, as shown in Figure 25-6. (The box on page 
25-12 tells you how to add a task to Timeline view in SharePoint.)

9.	 To add another task, repeat steps 2 through 8.

Page 25-12 describes how to add multiple tasks to a table.
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FIGURE 25-6
When you save a task, it 
appears in the Tasks List 
below the timeline. If you 
add a task to the timeline, 
its name and date range 
appear in the timeline 
at the top of the page. 
Tasks don’t appear on the 
timeline unless at least 
one date field has a value. 
If you want to change 
the task’s appearance 
in the timeline, click the 
timeline. When you do 
that, the ribbon displays 
the Timeline tab (not 
shown here), which has 
features similar to Project 
2013’s Timeline tab.

 TIP 	 Say you want to rearrange tasks to put them in a different order. First, select the task you want to move: 
to do that, put your cursor to the left of the task’s checkbox, and then click the checkmark that appears. Then, 
in the ribbon, click the Tasks tab. In the Hierarchy section, click Move Up or Move Down until the task is in the 
position you want.
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UP TO SPEED

Adding a Task to SharePoint’s Timeline View
Thanks to the growing sophistication of Web Apps, the Share-
Point 2013 Tasks app offers many features that are available in 
Project 2013, like Timeline view (page 619). For an overview of 
what’s happening when, Timeline view can’t be beat. You can 
add key tasks to Timeline View as bars or callouts. Here’s how:

1.	 With the Tasks List page open, in the ribbon, click the Tasks 
tab. It contains commands that help you create new tasks, 
indent and outdent tasks into an outline, attach files to 
tasks, and so on.

2.	 Put your cursor to the left of the task’s checkbox to see the 

selection checkmark. When the checkmark appears, click 
it to select the task. Sharepoint shades the background 
of the selected task’s row. A checkmark appears to the 
left of the task’s row, and the checkmark’s background is 
shaded a darker hue.

3.	 In the Tasks tab’s Actions section, click “Add to Timeline.”

4.	 The task’s name and date range appear in the timeline, 
as shown in Figure 25-6.

Adding, Editing, and Organizing Multiple Tasks
Opening a separate page each time you want to add or edit a task gets old quickly. 
With SharePoint 2013, you can edit several tasks right there on the Tasks List page. 
You can also indent and outdent tasks to create a hierarchy like the ones you’ve 
probably built in Project; or you can move tasks to reorder them. SharePoint 2013 also 
lets you change the way tasks are displayed. For example, you can display tasks in 
Gantt Chart view to look at the schedule. This section explains all those techniques.

EDITING MULTIPLE TASKS
Initially, the fields in the list of tasks aren’t editable. To edit a task, you have to click 
its name to open the page with its info, and then, in the ribbon’s View tab, click Edit 
Item. That’s a lot of clicks to make a simple edit or two. 

If you need to edit several task fields for several tasks, Quick Edit view makes editing 
much more efficient. Here’s how you edit tasks in Quick Edit view:

1.	 On the Tasks List page, above the column headings, click “edit.”

The Tasks List switches to a table that looks and acts a lot like an Excel spread-
sheet, as shown in Figure 25-7.
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FIGURE 25-7
Clicking “edit” on the 
Tasks List page (not 
shown here) switches the 
Tasks List to Quick Edit 
view. Task values are dis-
played in a table, so you 
can click the cell you want 
to edit, and change its 
value right there. When 
you’re finished editing, 
click Stop, and the Tasks 
List switches back to the 
standard list view.

2.	 Click a cell, and then edit its value.

SharePoint outlines the selected cell with a bold border.

3.	 Repeat step 2 to edit other cells in the table.

If you click a cell in a different row, SharePoint saves the edits you made to the 
task in the row you just clicked away from.

4.	 When you’re finished editing, click Stop above the column headings.

The table disappears and the tasks revert to a read-only list.
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ORGANIZING A TASKS LIST INTO SUMMARY TASKS AND SUBTASKS

For all but the smallest of projects, a work breakdown structure helps keep tasks 
organized. By grouping subtasks beneath summary tasks, it’s easier to identify the 
work that needs to be done and how much of that work is complete (page 123). You 
can organize tasks in this same way in SharePoint. Although the steps are slightly 
different than the ones in Project, the resulting hierarchy is similar.

To organize your Tasks List, first open it (click Site Contents and then click the 
icon for the appropriate Tasks List). Above the Tasks List, click “edit.” SharePoint 
switches to Quick Edit view (page 25-12). Here’s how you work with summary tasks 
and subtasks in a SharePoint Tasks List: 

•	 Change a task into a subtask. In your Tasks List, put your cursor over the sub-
task’s name, and then click the checkmark that appears to the task’s left. In the 
Tasks tab’s Hierarchy group, click Indent. SharePoint indents the selected task, 
and turns the task above into a summary task, as shown in Figure 25-8. You can 
expand and collapse summary tasks to show or hide their subtasks. Just like 
you do in Project, click the black triangle to the left of a summary task’s name 
to hide its subtasks; click the white triangle to the left of a collapsed summary 
task to show its subtasks. 

•	 Outdent a task. In your Tasks List, place your cursor over the subtask’s name, 
and then click the checkmark that appears to the task’s left. Then, in the Tasks 
tab’s Hierarchy group, click Outdent. SharePoint moves the selected task up 
one level in the hierarchy. If the task above was a summary task, it changes 
back to a regular task.

•	 Create a new subtask under another task. Click the ellipsis to the right of the 
summary task’s name. On the menu that appears, click Create Subtask.
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FIGURE 25-8
The summary task’s name 
is bolded and a black 
triangle appears to its 
left, just as it does in a 
Project 2013 summary 
task. Click this triangle to 
hide the summary task’s 
subtasks.

WORKING WITH SHAREPOINT TASK VIEWS
SharePoint task views let you control how your tasks appear. For example, you can 
display tasks in Gantt Chart view or choose Upcoming to filter the Tasks List to 
show the tasks that are on deck. Here are some of the things you can do with views 
in SharePoint 2013:

•	 Apply a different view to your Tasks List. Click the ellipsis to the left of the “Find 
an item” box, and then choose the view you want. If you choose Gantt Chart, 
you’ll see a Gantt Chart view similar to the one in Project 2013. (It has a table 
with column on the left and a timescale on the right. The table in Gantt Chart 
view works much like the one in Project, so you can edit values directly in cells.)
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•	 Modify a view. To modify the current view, click the ellipsis, and then, choose 
“Modify this View.” The Settings→Edit View page that appears includes view 
settings similar to the ones in Project 2013: the columns to include and their 
order, sorting, filtering, grouping, and so on. The main difference is that you 
choose the settings in a web page instead of a dialog box. Page 25-19 describes 
how to add additional columns of information to a view.

•	 Create a new view. To create a view from scratch, click the ellipsis, and then, 
choose “Create View.” On the Settings→View Type page that appears, choose 
the type of view you want, such as Standard View for the read-only Tasks List, 
Datasheet View for an editable table, or Gantt View for the old standby Gantt 
Chart presentation.

Exchanging Task Info Between Project 
and SharePoint

Project and SharePoint Tasks Lists play well together up to a point. (The box below 
explains the limitations to the Project-SharePoint Tasks List relationship.) You can 
publish tasks in a Project file to a SharePoint Tasks List or take tasks in a SharePoint 
Tasks List and add them to a Project file.

Once you set up that initial connection between a Project file and a SharePoint 
Tasks List, you can synchronize the info they contain so it appears in both places. 
That way, the entire team can see what’s going on with the project at all times. This 
section explains how to do that.

GEM IN THE ROUGH

Tasks Lists Have Their Limits
SharePoint doesn’t have the scheduling prowess that Project 
does. So before you synchronize your Project with SharePoint, 
see whether SharePoint’s features satisfy your needs:

•	 Task start and finish dates are set with date constraints. 
SharePoint can’t calculate project schedules, so tasks you 
synchronize appear in SharePoint Tasks Lists as manually 
scheduled (page 60). In Project, the tasks are still set to 
Auto Scheduled mode, but the task dates include partially 
inflexible date constraints like Finish No Later Than. 
That means you have to manage links between tasks as 
dates change, and resolve any resource overallocations 
that occur.

•	 Resources assigned to tasks must be members of the 
SharePoint site. The only resources you can see in a 
SharePoint Tasks List are people who are members of the 
SharePoint site. If you assign other resources to tasks, the 
Assigned To values for those tasks are blank. However, 
the resource assignments still exist in your Project file.

•	 Custom fields that use formulas don’t synchronize. On the 
bright side, custom fields without formulas do synchronize 
to SharePoint. See page 25-20 for info on adding fields to 
a SharePoint Tasks List.
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Creating a SharePoint Tasks List from a Project File
If you build a project schedule in Project, chances are you want to share that schedule 
with your team, so they can see what they’re supposed to do and what’s happening 
in the project. Publishing your schedule to a SharePoint Tasks List makes your proj-
ect tasks easily accessible on a SharePoint site (as long as the limitations described 
in the box on page 25-16 are acceptable to you.) Here’s how you publish tasks in a 
Project file to a SharePoint Tasks List:

1.	 Open the Project file you want to publish to SharePoint, and then choose 
File→Save As→“Sync with SharePoint.”

The “Sync with SharePoint Tasks List” fields appear to the right of Backstage 
view’s Save As page.

2.	 To create a new SharePoint site for the project, in the “Sync with” box, keep 
New SharePoint Site selected. In the “Project name” box, type the project 
name you want to use for the site. And in the “Site address” box, type the 
URL for the SharePoint site to which you want to add the project site, as 
shown in Figure 25-9. Then, skip to step 6.

If you’ve added the SharePoint site to your Project Save As locations (page 25-
2), you can click the down arrow in the “Site address” box, and then choose the 
SharePoint site URL. The program appends the project name to the SharePoint 
URL to create the project site address. For example, if the SharePoint URL 
is https://projecttmm.sharepoint.com and the project’s name is Fundraiser, 
then the project site address becomes https://projecttmm.sharepoint.com/
Fundraiser.

FIGURE 25-9
When you fill in a Share-
Point site address and 
click Verify Site, Project 
connects to the site, and 
then populates the Tasks 
List drop-down list with 
the existing Tasks Lists.
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3.	 To sync with an existing SharePoint site, in the “Sync with” box, click the 
down arrow, and then choose Existing SharePoint Site (see Figure 25-9).

If you choose this setting, you don’t have to enter a project name, because the 
SharePoint site already has a name.

4.	 In the “Site address” box, type the existing site’s SharePoint URL. Alter-
natively, click the down arrow, and then, in the drop-down list, choose the 
SharePoint site you want.

Don’t include the name of the Tasks List in the URL.

5.	 Click Verify URL.

Project connects to the site and retrieves the names of its Tasks List.

6.	 In the Tasks List drop-down list, choose the Tasks List you want to sync the 
Project file to.

The Tasks List drop-down list contains existing Tasks Lists from the site you 
verified.

7.	 Click Sync.

A “Sync with Tasks List” message box keeps you posted on the synchronization 
process. If any of the resources you’ve assigned to tasks don’t exist within the 
SharePoint server, a warning tells you that those resources won’t be published. 
Click OK to continue. Although you won’t see the resource names in the Share-
Point Tasks List, the assignments remain in your Project file.

Your Project tasks are now published to the SharePoint site. You can see them by 
navigating to the SharePoint site in your browser.

Saving a SharePoint Tasks List to Project
Creating a list of tasks on a SharePoint site is an easy way to start a project sched-
ule. For simple projects, creating and managing tasks on the SharePoint site may 
be enough. But if your simple project morphs into something bigger, you can save 
your SharePoint Tasks List to Project, and then use Project’s more comprehensive 
tools to keep the schedule under control.

Here are the steps for saving a Tasks List to Project:

1.	 Open the Tasks List you want to save to Project by clicking Site Contents 
on the SharePoint site Home page, and then clicking the icon for the ap-
propriate Tasks List. 

If you opened the Tasks List recently, you can click its name below the Recent 
heading on the page’s left.

2.	 In the ribbon, click the List tab. Then, in the Connect & Export section, click 
“Open with Project.”
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Project 2013 launches and displays the tasks from the SharePoint Tasks List in 
a new Project file. (If you have an earlier version of Project installed, a message 
box tells you that you need Project 2013.)

3.	 Click Save.

A “Sync with Tasks List” message box tells you the progress it’s making. When 
the synchronization is complete, the tasks from SharePoint appear in the cur-
rent Project view.

From now on, you can synchronize any changes you make in Project or SharePoint, 
as described in the next section.

Synchronizing Changes
When you connect a Project file and a SharePoint Tasks List, the process includes 
an initial synchronization that sends the info from one program to another. For 
example, if you publish a Project file to a SharePoint Tasks List, the synchronization 
pushes the tasks in Project into the SharePoint Tasks List. As you know all too well, 
a project is dynamic, so you’ll want to synchronize future changes, whether they 
occur in Project or SharePoint. Fortunately, synchronizing is easy: once your Project 
file is connected to a SharePoint Tasks List, you can sync the two simply by saving 
the Project file within Project (choose File→Save). Or you can choose File→Info, 
and then click Save.

 NOTE 	 If you and someone on your team both modify the same field—one in Project and the other in Share-
Point—when you go to synchronize, Project will display a Conflict dialog box, which includes a Microsoft Project 
Fields column and a SharePoint Fields column. The fields whose values differ between the two are highlighted. 
For each conflict, you need to specify whether to keep the value from Project or SharePoint. To keep a value 
from Project, in the conflict’s Version column, click the down arrow and then choose Microsoft Project Version. To 
use the value from SharePoint, click the down arrow, and then choose SharePoint Version instead. After you’ve 
specified which version to keep for all the conflicts, click the Continue Sync button.

Managing the Fields in a SharePoint Tasks List
Once a connection exists between a Project file and a SharePoint Tasks List, you can 
specify the fields that appear in the Tasks List. For example, you can add the WBS 
field, a cost field, or a custom field to the SharePoint view. (The box on page 25-22 
tells you why adding the WBS field can be helpful.) Here’s how to sync additional 
fields to a SharePoint Tasks List or edit the settings for existing fields:

1.	 In Project, choose File→Info.

Once a Project file is linked to a SharePoint Tasks List, the Info page includes a 
Save button with the label “Save and Sync Your Project.” In addition, you can 
see when the file and the Tasks List were last synchronized, as well as the site 
address and the Tasks List that the Project file is synced to.
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2.	 Below the “Save and Sync Your Project” information, click Map Fields.

The Map Fields dialog box opens, showing the fields in the Project table and in 
SharePoint. A checkmark in the Sync column indicates that the corresponding 
field synchronizes between the two programs. In the dialog box, some fields 
are grayed out to indicate that you can’t change whether they synchronize. For 
example, the Name, Start, Finish, % Complete, Resources Names, and Predeces-
sors fields are automatically synchronized.

3.	 To add a field, click Add Field. In the Add Field dialog box, choose the 
Project field you want to add, such as WBS (as shown in Figure 25-10), and 
then click OK. 

The checkmark in the Sync column is turned on automatically. Project auto-
matically copies the field’s name to the SharePoint Column box. If you want 
the SharePoint column to use a different heading, then type the name in the 
box before you click OK.

4.	 To change the SharePoint column’s name, in the Map Fields dialog box, type 
the new name. Turn the checkmark in a Sync cell off if you no longer want 
to synchronize the field.

5.	 When you’re done mapping fields, click OK again to close the Map Fields 
dialog box, and then click Save.

You have to click Save to send the info from the new fields to SharePoint.

6.	 Back in the SharePoint Tasks List, click the ellipsis to the left of the “Find 
an item” search box, and then choose “Modify this View.”

The Settings→Edit View page appears.

7.	 To display a field in the view, turn on the field’s checkbox. Then click OK.

To reorder the columns in a view, in the “Position from Left” column, fill in the 
column number to specify the field’s position in the table.
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FIGURE 25-10
To map additional Project 
fields to a SharePoint 
Tasks List, click the Map 
Fields button below the 
“Save and Sync Your 
Project” info. The Map 
Fields dialog box lists 
the fields that appear 
in the Project view and 
in the SharePoint Tasks 
List. If you want to add 
other Projects fields, 
click Add Field. Then, you 
can choose the field you 
want to add and specify 
the name to use in the 
SharePoint column.
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WORKAROUND WORKSHOP

Keeping Tasks in Order
The “Sync with Tasks List” feature has an annoying idiosyn-
crasy: Sometimes when you synchronize tasks, they come 
across in seemingly random order. Links to predecessors don’t 
help. In Project, you can easily sort the list (page 355) by ID 
number, WBS code, or any other field to order it the way you 
want. Fortunately, you can sort tasks in SharePoint by adding 
the WBS field to a SharePoint Tasks List view. Then you can 
sort the Tasks List to match the order in your Project file. Here 
are the steps:

1.	 Add the WBS field to the SharePoint view, as described 
on page 25-20.

2.	 Synchronize your Tasks List to transfer the field values to 
SharePoint (page 25-16).

3.	 In the SharePoint Tasks List, click the ellipsis to the left 
of the “Find an item” box, and then choose “Modify this 
View.”

4.	 Turn on the WBS field’s checkbox and click OK.

5.	 On the Tasks List page, put your cursor over the WBS 
heading, and then click the down arrow that appears. In 
the drop-down list, choose “A on Top.”

Updating Progress in a SharePoint 
Tasks List

You and your team members can view and edit values in SharePoint. But SharePoint 
doesn’t offer the variety of progress update methods that Project does. For example, 
team members can change values in the % Complete field or change a finish date 
for a task. However, once you enter % Complete values or finish dates, you can 
synchronize the changes (in Project, choose File→Info→Save) to bring them back 
into Project. Here’s how to update task status in SharePoint:

1.	 On the left side of the site, click Site Contents, and then click the Tasks List 
you want to work on.

The Tasks List page opens.

2.	 To see the tasks you’re assigned to, click the ellipsis to the left of the “Find 
an item” box, and then choose My Tasks.

The Tasks List displays only the tasks to which you’re assigned.

3.	 Click the task to open it on its own page. Then, in the View tab’s Manage 
section, click Edit Item.

The fields on the page become editable.
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4.	 In the % Complete box, type the percentage of the work that’s complete, 
as shown in Figure 25-11.

If you want to update other values, such as Finish Date or Work, you can add 
those fields to SharePoint as described on page 25-20. Those fields then ap-
pear on the task’s edit page. That way, you or your teammates can fill in the 
field values. When you sync the Tasks List and the Project file, those values 
propagate to your Project schedule.

FIGURE 25-11
Fill in the % Complete 
field with the current 
percentage complete. 
If you map additional 
fields from Project into 
SharePoint, you can fill 
in other status values 
here, too.

5.	 Click Save.

The updated values appear in the Tasks List. If you synchronize the tasks with 
Project, the updated values appear in your Project schedule.
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